< 返回上层

Linux下安装scapy-python3

2018-01-12 16:24:40 1330次

环境:

centos6.4
python3版本

安装scapy

pip3 install scapy-python3yum install libffi-devel
pip3 install cryptographyln -s /opt/python/bin/scapy /usr/bin/scapy

安装完成后运行scapy:

[root@localhost ~]# scapy
INFO: Can't load Python libreadline or completerWARNING: No route found for IPv6 destination :: (no default route?). This affects only IPv6
INFO: Please, report issues to https://github.com/phaethon/scapyWARNING: IPython not available. Using standard Python shell instead.
Welcome to Scapy (3.0.0)>>>

 

解决Can't load Python libreadline or completer的问题:

yum install readline-develyum install patchpip3 install readline

 

再次运行scapy,这时已经支持自动补全了:

[root@vnode33 ~]# scapy
WARNING: No route found for IPv6 destination :: (no default route?). This affects only IPv6
INFO: Please, report issues to https://github.com/phaethon/scapyWARNING: IPython not available. Using standard Python shell instead.
Welcome to Scapy (3.0.0)>>>

 

Session saving/loading functions require dill library:
pip3 install dill


提交成功!非常感谢您的反馈,我们会继续努力做到更好!

更多建议

这条文档是否有帮助解决问题?

没有帮助 有帮助

非常抱歉未能帮助到您。为了给您提供更好的服务,我们很需要您进一步的反馈信息:

在文档使用中是否遇到以下问题: